TestTrack TCM Quick Start Guide

This guide is provided to help you get started with TestTrack TCM and answer common questions about
working with test cases and test runs. Your use of TestTrack may be different based upon your organization’s
testing process, but the same basic concepts apply.

How does our manual process translate to TestTrack TCM?

TestTrack TCM is ready to use out of the box, but can also be customized to fit your terminology,
methodology, and regulations. Before your organization begins to use TestTrack TCM, it is important to take
the time to evaluate and document each step in your testing process. Consider the following questions:

= What actions need to be performed?

= Who is responsible for performing each action?

= What data needs to be tracked for each action?

= What is required to move to the next step in the process?

This can help you determine how to use TestTrack TCM to automate and improve your process. The
TestTrack TCM administrator or another high-level user is generally responsible for customizing TestTrack
TCM.

Workflows

TestTrack TCM includes default test case and test run workflows. To move a test case or test run through the
workflow, it is assigned to users who perform the required work. The workflows can be customized to adapt to
your testing process or used as is.

The following diagram shows a high-level overview of the testing process supported by the default TestTrack
TCM workflows.
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Test items

The test items used in your manual process are all represented in TestTrack TCM. In your process, you may
have created a checklist of items to test. When a new product version required testing, you printed the
checklist and wrote the test results on it. These items are all used in TestTrack TCM.

= The checklist is a test suite. In TestTrack TCM, folders or custom fields can be used to group related
test cases in test suites.

= Each line in the checklist is a test case.

= The printed checklist is a test run set. In TestTrack TCM, you can add new test runs to test run sets,
which can help you report on each test initiative and determine the current status.

= Eachitem in the printed checklist is a test run. In TestTrack TCM, test runs are generated from test
cases at a milestone in the testing process. Testers use test runs to perform a test and enter the
results.

The following diagram shows the relationship between these components.
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How do | install TestTrack TCM?

The TestTrack installation program installs TestTrack TCM and TestTrack Pro, Seapine’s defect
management tool. You must have a valid TestTrack TCM license to work with test cases and test runs, even
if you already use TestTrack Pro.

Make sure you have the following information from your TestTrack administrator:

= TestTrack Server address and port number—TestTrack projects are stored on servers. You need to
add a connection to a server before you start using TestTrack TCM.

= Your TestTrack username and password—Y ou need a username and password to log in to the
TestTrack Server. Your organization may use single sign-on, which allows you to log in using your
network credentials. Ask your TestTrack administrator for information about single sign-on.



How do | enable TestTrack TCM?

How do | enable TestTrack TCM?

The TestTrack administrator may need to enable TestTrack TCM for the project if you cannot access test

cases or test runs.

1. Choose Tools > Administration > Project Options.

The Project Options dialog box opens with the General category selected.

2. Select Allow TestTrack TCM users to log in to this project.
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Users with TestTrack TCM licenses can access test cases and test runs the next time they log in.

What are test cases?

Test cases are the core component of TestTrack TCM. Test cases include all information about a test,
including the description, scope, conditions, detailed steps, expected results, scripts, and other test data.
Each test case should focus on only one component or requirement.

To work with test cases, choose View > Test Cases to open the Test Cases list window.
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What are test runs?

Test runs are instances of a test case used to perform a test and document the results. Test runs are
generated from a test case, typically at a milestone in the testing cycle. All information is copied from a test
case to the related test runs.

A single test case can have one or more related test runs, which are performed against different builds or
configurations.

To work with test runs, choose View > Test Runs to open the Test Runs list window.
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What are the differences between test cases and test runs?

Test cases generally do not change unless they include incorrect information or the tested application
changes. They remain open and are reused to test subsequent builds and releases. Test cases are not used
to perform tests and do not include results.

Test runs are only used once to perform a specific test during a testing cycle. Test runs include the test
results and are closed after the specific test is performed.

What information should a test case include?

A test case should include all the information a tester needs to successfully perform a test. It is important to
include complete information to avoid ambiguity during testing. All the test case information is copied to test
runs when they are generated.

Test cases generally include the following information:

= Details—The estimated time to perform the test, a description of the scope of the test, any test
environment setup information or other requirements that must be in place before the test is performed,
and the expected outcome of the test. Your organization may also use custom fields to capture
additional information in the test case details.

= Steps and expected results—The specific actions the tester needs to perform, in sequential order.
Expected results can be added to each step to describe the outcome of completing the step.



How do | use a single test case to support multiple configurations?

= Supporting files—Any files that can help the tester perform the test can be attached to a test case. You
can attach automated scripts, source code files, or other files, such as requirements, test data, or
screenshots.

To create a test case, choose Create > Test Case or click Add on the Test Cases list window.
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How do | use a single test case to support multiple
configurations?

If the same test needs to be performed against different builds or configurations, you can use one test case to
cover all the required tests.

TestTrack TCM includes test variants, which represent the variable elements of an application that need to be
tested, such as multiple platforms, databases, or client types. When you generate test runs, you select the
test variant values to use. A test run is created for each unique combination of the selected variant values.

For example, if you test a Web-based application in multiple browsers, you can create a Browser test variant
with Internet Explorer, Firefox, Safari, and other browsers as the variant values. When you generate test runs,
TestTrack TCM generates unique test runs for each browser you select.

The TestTrack administrator or another high-level user generally configures test variants. To create test
variants, choose Tools > Custom Fields and then select Test Variants as the record Type.



How do | make sure that only valid test variants are used?

When you generate test runs, every test variant value is available. While this makes it easy to quickly
generate a large number of test cases, you could end up with dozens of test runs that do not apply to the test
case. Instead, you can add the variant values in test cases to always include or exclude them when test runs
are generated.

= |ncluded test variant values are always used to generate test runs. If you add included test variant
values to a test case, no other values will be used to generate test runs.

= Excluded test variant values are never used to generate test runs. If you add excluded test variant
values to a test case, all values except the excluded values will be used to generate test runs.

To include or exclude test variant values in test cases, click the Variantstab in the Add Test Case or Edit Test
Case window.

4 ] . 9
Orerview Detail J,E Steps Varianks m:| Files | [ Test Runs @E Sorkflow @ Links | [] Folders | &2 Histary

Included Tesk Yariant Yalues

Included test variant walues are the only walues that can be tested for this test case. Other walues currently in the kest variant of any values that
you add laker cannot be tested.

Wariant Mame Yalue &dd Yariant. ..

Client Type Mative Client
Edit Yariant...

Femave Yariant,..

Excluded Test Yariant Values

Exchuded test watiant values will not be tested For this test case, Other values currently in the test wariant or any walues that wou add later can be
tested.

Wariant Mame Yalue &dd Yariant. ..

Database Cracle
Edit Yariant...

Femave Yariant,..

Note: If you add included test variant values and do not add excluded values, all test runs include all
variant values. Make sure you add excluded test variant values if the test case does not apply to a
specific variant value.

When should | generate test runs?

Test runs are typically generated when test cases are complete and the product is ready for testing. You may
want to generate test runs at the beginning of each testing phase so you can more easily track the test cases
that test runs have been generated for. This can also help you evaluate how many test runs still need to be
performed so you can determine the status of the testing cycle. For example, you may generate test cases at
the beginning of the Alpha testing phase, at the beginning of the Beta testing phase, and for each Beta build.

Depending on your organization’s workflow, you may only be able to generate test runs from test cases ina
specific state. For example, the default test cases workflow only allows you to generate test runs for test
cases in the Ready state.



How can | organize test cases and test runs?

To generate test runs, select a test case on the Test Cases list window and choose Activities > Generate
Test Runs.
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How can | organize test cases and test runs?

You may already use test suites. In TestTrack TCM, you can use folders or custom fields to represent test
suites. For example, you can create folders to store regression test cases grouped by product component.
You may also add related test runs to a sub-folder to group the related items. The following example shows
how folders can be used to create test suites.
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g Test Case 4 Login - users can only see projects they have permissions for - Active, not assigned
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Test run sets are designed to group related test runs. Test runs can be added to test run sets when they are
generated. Test run sets are similar to folders, but the test run set is displayed in the Edit Test Run and View
Test Run windows. For example, you may want to create a test run set for each milestone in the testing cycle.
This can help you when it is time to generate reports to evaluate testing progress.



The TestTrack administrator or another high-level user generally configures folders, custom fields, and test
run sets.

How do | use a test run to perform a test?

When a test run is assigned to you, take the time to review it before you perform the test. Open the test run
and review the following information:

= The Variants tab includes the environment to use to perform the test. These are the test variant values
that were selected when the test run was generated from the test case.

= The Detail tab includes general information about the test, including any setup instructions.

= The Files tab includes any files you may need to perform the test, including automated scripts,
screenshots, or other test data.

= The Steps tab includes the steps and expected results that you use to perform the test.

Perform each step exactly as described on the Steps tab. If the actual result of performing a step is different
from the expected result, add a problem statement to explain the issue. You can also attach files, such as
screenshots, script reports, or source code files, to the test run to report results.

Finally, you need to indicate if the test passed, failed, or if the results were unclear. For example, if your
organization uses the default test runs workflow, choose Activities > Enter Results. You can select
Passed, Failed, or Result Unclear (Needs Review) as the resulting state to indicate the test result. The test
run moves to this status when you save it.

How do | print test runs to use when performing a test?

You can print detail reports to use when you perform a test. To create a test run detail report, choose Create >
Report and choose Detail. Select Test Runs from the Report contains field.

Test run detail reports include all information about a test run. You can use this report to review the workflow
for a test run to understand where it stands in your testing process and the next steps. To print the report, click
the Print button in the Edit Test Case dialog box and make sure the TestRunDetailReport.xslt stylesheet is
selected.

Test run checklist reports include the test run details in a format you can use for handwritten information. You
can use this report to perform a test and capture the results if TestTrack TCM is not installed on the test
computer or you want to write the results before entering them in TestTrack TCM. To create this report, make
sure the TestRunStepsDetailReport.xslt stylesheet is selected. The following example shows a test run
checklist report.



What should I do if a test fails?

@ Test Run Checklist

Test Run Number: 1

Test Case Number: 1
Summary: Login - User sees only projects that match their security settings for projects
Status: Passed

Type: Security Is An Automated Test: false Tast Run Set: Version 2 Alpha
Steps: Step  Step Expected Result
#
O 1 Start TestTrack Client O
O 2 on the server login screen, log in with the newly created user to the server that contains O
the projacts from the set up steps
O Click Connect Verify that the Project login screen appears O
O Verify that ONLY the projects the user is assigned to are listed  [[]
with the project drop down

O Select one of the projects O
O 3 Click DK verify tha uzar iz loggad into the praject O
© d Test ¢ ge Athi : Attribute Name value

Operating System Yariant Salaris

Database Variant MySGL

Run Results

Date and time you started this testrun:

Date and time you completed this test run:

How much time did it take you to complete this test run?

Waere any additional test variants tested?

Whatwas the result of this test run? [ passed [ raited [ unclear
Describe any pi ene din ing these steps (include a step number and g d defect number if passible):
Signature: Date:

What should | do if a test fails?

If your organization uses a defect management tool, add a defect for the failed test to push the failure into your
workflow so it can be fixed and retested.

If your organization uses TestTrack Pro, you can add a defect from the failed test run. The test run information
is copied to the defect so other users can review the steps to reproduce the problem when fixing the defect or
verifying the defect fix.

To create a defect from a test run, click Create Defect in the Edit Test Run dialog box.



® Add Defect

Summary: |Test Run 14: Login - User sees only projects that match their security settings for projects - The list contains all projects, not just the pi

Status: Open, not assigned Disposition: |<n0t sekx v|
Type: |Inc0rrect Functionality v| Priority: |Before Alpha v|
Product: |Pr0ductA v| Component: |C0mp0nent2 v|
Reference: | | Severity! |N0 ‘workaround v|
Entered By: |Administrat0r, Syskem v|@ Date Entered: E]
‘ersions Impacted: |<n0t sekx v|

Overview |ﬁ Eetail |@E workflow ﬂ ‘Workaround &_\ Source Code @ Email @ Links | [] Folders | 2 History

Current Repart: |Administrator, System - 1712009 V| 1of1 |1 £ | Mew Remove
»
j] Reproduced:
’_ Steps to Reproduce:
421  |5tep 1: Start TestTrack Client
—— |Step 2: Onthe server login screen, log in with the newly created user ko the server that contains the projects from the set up steps
Step 3 Click Connect
IEIE|
Problem: The list contains all projects, not just the projects the user has access to,
Skep 4 Select one of the projects
@ Step 5 Click OF
Apply ] I Add l [ Cancel

After the defect is fixed, you can regenerate the test run so the test can be performed again.

How do | determine how much testing remains?

You can create a distribution report based on test run sets to view a snapshot of test runs at a specific point in
the testing cycle. For example, as you approach the end of the Alpha testing phase, generate a distribution
report based on the Alpha test run set to see how much testing remains. To create a test run distribution
report, choose Create > Report and choose Distribution. Select Test Runs from the Report contains field.

Test run status by test run set reports includes the status of test runs in each test run set. This report can help
you determine how many test runs are waiting, in progress, on hold, or completed for each test run set. To
create this report, select the Status by option and then select Test Run Set from the corresponding list. The
following example shows the test run status report.
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How do | determine how much testing remains?

@ Test run status by test run set

Report Period: from first test run found through last test run found

Version 2 Alpha Version 2 Beta WVersion 2 BetaBuild1 Version 2 BetaBuild2 Totals
Mot Started a a 1} 13

13
In Progress 0 0 G 3 9
Passed 16 13 3 a 35
Failed 4 ] 4 0 16
Closed (lgnored) 0 3 1] 0 3
Totals 20 24 16 16

Overall status

Closed (Ignorgd

"R

In Progress
12%09

Test run result status by test run set reports include the test run results for each test run set. These reports
can help you determine how many test runs in each test run set are passed, failed, or undetermined. To create
this report, select Run result status by and then select Test Run Set from the corresponding list.

11






	TestTrack TCM  Quick Start Guide
	How does our manual process translate to TestTrack TCM?
	Workflows
	Test items

	How do I install TestTrack TCM?
	How do I enable TestTrack TCM?
	What are test cases?
	What are test runs?
	What are the differences between test cases and test runs?
	What information should a test case include?
	How do I use a single test case to support multiple configurations?
	How do I make sure that only valid test variants are used?
	When should I generate test runs?
	How can I organize test cases and test runs?
	How do I use a test run to perform a test?
	How do I print test runs to use when performing a test?
	What should I do if a test fails?
	How do I determine how much testing remains?

